No announcement yet.

Seph's Big FAQ for Tech Issues!

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    Seph's Big FAQ for Tech Issues!

    Courtesy of our Tech God Seph on common issues:

    What is required to run one of your games?
    Operating System:
    Windows 10 (32-bit or 64-bit)
    Windows 8 (32-bit or 64-bit)
    Windows 7 SP1 or later (32-bit or 64-bit)
    Windows Vista SP2 or later (32-bit or 64-bit)
    Mac OS X 10.6.8 or later with Parallels Desktop 7+ or VMware Fusion 4+
    .NET Runtime .NET 4.0 or later
    Adobe Flash Player Adobe Flash Player 10.3 or later

    I have a Mac/Linux machine and no access to parallels or a VM, can I still play your games?
    You can, it just gets much harder. The games currently publish with a .exe executable required to run the game player. You can circumvent this by setting up a web server and hosting the game. A simple resource to follow that goes through terminal setup is below but you can also find many GUI based applications as well if you wish to go that route.

    I have noticed the game comes with both .exe and .html starters, can I use both?
    Unless you have setup a web server to host the html file you MUST use the .exe file. The .exe file essentially emulates a web environment and hosts the html file, without it or your own web server several functions of the games will not work.

    When I open the game I get either a white screen, infinite loading screen or a message that says a slide cannot be viewed.
    Make sure you are correctly running the .exe file or your web server is configured correctly to host the game. If you are still having issues, make sure your machine meets the basic requirements and if all else fails consider updating to a newer version of flash or rolling back to a previous release. The games do not provide interpretation and rely on your machine to do things such as load video/images and handle audio.

    The version of flash I have installed is not working, where can I download it?
    You can download the latest version of flash for your system here:
    If you wish to roll back to an archived version of flash, you can find those here:

    Can I make a save and come back to the game later?
    There is no manual save feature built into our engine and making one from scratch is a labors task. Instead the game has auto-save and if quit will give you the option to resume at your current place.

    Always working behind the scenes

    I just wanted to post a work around that I have found that seem's to be a pancea for most of the problems that I have run into. This was mentioned in the FAQ in mysteria lane, but hasn't been put in the other games (if others find that it works we might want to consider putting it in the resources tabs of most games Selectacorp )

    The fix is this:

    paste that link into the browser of your choice.

    A screen Like the one attached below should come up.

    Click on edit locations drop box on the bottom right

    click on add locations from the drop down menu that comes up

    click on browse for folders

    *Single* click on the folder that contains the unzipped game/arcana you downloaded and click the open button.

    Exit out, launch the HTML file in the folder with the same browser you just used to open the flash settings page.

    I've successfully been able to play every game on both windows and Mac OS's using this strategy with firefox, even when flash updates made the .exe act wonky.
    Please gentlemen, no fighting in the war room.


    • Selectacorp
      Selectacorp commented
      Editing a comment
      Thanks for this Strangelove

    • Strangelove
      Strangelove commented
      Editing a comment
      Happy to help...

      Also should mention one caveat: I think sometimes this method can occasionally introduce some bugs (probably due to this not entirely emulating the "web enviroment" that you mention above). For example using this method the save/resume feature doesn't work for me. Also for some reason it will work for me in Firefox and safari but not chrome because chrome won't let me select a folder under the flash permissions. I would thus recommend trying a few browsers if the first one you try doesn't work. However SOTU, S2S and most of the other recent games seem to work flawlessly for me (except for the save feature) on OSX using this method.
      Last edited by Strangelove; 12-23-2016, 12:31 AM.

    I'm unable to get Corporate Raider 3 and some other flash games to load from the site. I've tried tweaking settings but nothing seems to do the fix. I'm on Windows 10. Whenever I open the game, the following pop up is displayed. I can't click Allow and I can't click Deny. I can't sidestep it in any way that I've found.
    Attached Files


    • Sephrith
      Sephrith commented
      Editing a comment
      Hey Nintendoboy80, I know you have said you've already tried a few setting changes but if you haven't already give this a try for me. Go over to Control Panel > Flash Player > Storage and select "Allow sites to save information on this computer" or "Block all sites from storing information on this computer". The only benefit saving files for the Selectacorp games is being able to resume from the auto save, however most games can be completed in a single sitting so I would base your decision more on other sites you use that handle flash if you visit any.

      My primary reason for hitting this first is flash and many other plugin style applications often struggle with presence and click-jacking. This basically means that they can't always tell which application is on top so while to you it looks like you are clicking the allow button the plugin sees you clicking the desktop or game title screen. By giving flash player a set rule for how to handle local storage it shouldn't need the pop-up anymore and avoid triggering it all together. It's a bit of a work around more than a true fix but I've seen dozens of companies struggle with this sort of issue in their applications for years and it does not show any signs of letting up so I don't think there is much point in trying to cycle through flash versions if this gets you up and playing.

    • Nintendoboy80
      Nintendoboy80 commented
      Editing a comment
      Wow, thanks Seph. I'd previously checked the settings for Flash before and confirmed that I had "Allow sites to save information on this computer checked" but I never thought to uncheck it. I tested it with "Block..." selected and the game opened without a pop-up just fine. Strangely, I toggled "Allow..." back on and the pop-up went away as well. I'm not sure I understand why that fixed it, but your advice was spot on. Thank you.

    • Sephrith
      Sephrith commented
      Editing a comment
      No problem at all, anytime. Glad to hear you're back up and playing!

    Adobe Flash player is no longer available. I can't even install it. Any other alternatives?